SharePoint 2010 vs 2007 solution

Feb 19, 2010 at 3:07 PM

I have SharePoint 2010 on my windows 7 64bit, how do i target 2007 when wspbuilder builds my solution.  It's building it as 2010 compatible, but i'd like to build it for 2007.

Mar 5, 2010 at 10:54 AM

Did you ever resolve this? I have the same problem when recompiling an existing 2007 Project with the latest WSPBuilder that is included in 1.4.

Not sure if the OS matters, but I am running Win2K8 R2 64

Mar 8, 2010 at 3:48 PM

No, it seems the current wsp builder auto targets the SharePoint version that is installed.  I had to compile the project on a vm with SharePoint 2007.  I couldn't find a switch in the documentation that would allow me to target SharePoint 2007 despite having 2010 installed.

Mar 10, 2010 at 8:41 AM

Would have been nice to have a switch. I just verified and it looks like you need to compile any hybrid applications, that target both SharePoint versions, on a system with SharePoint 2007 installed.

I am currently planning a series of blog posts about moving SharePoint 2007 based WSPBuilder Applications to SharePoint 2010. Keep an eye on my blog feed