Deploy Command disabled when WSP name is different from the folder name

Dec 16, 2008 at 10:23 AM
When you change the WSP name other than the folder name in the config file in the WSP builder project, the deploy command does not detect that the WSP is created. it always assumes that the file is with the same name of the folder.

i believe the issue is in the WSPFileHandle.cs in the following line
string wspFilePath = this.SelectedProject.DirInfo.FullName + @"\" + this.SelectedProject.DirInfo.Name + ".wsp";

it should not depend on the folder name, but read the name from the config file if found.

did anyone find a work around for this issue?

BTW. This tool is a life saver, i depend on it for all our projects. Way to go.

Jun 16, 2009 at 2:12 PM
Edited Jun 16, 2009 at 6:13 PM

It's working ok for me. But i'm not renaming the file, i'm using the WSPBuilder.exe.config file and the WSPName setting.


I've managed to find out a workarround. You have to first build and deploy the WSP without the config file. After that, just delete the WSP package add the WSPBuilder.exe.config after that it will work using the WSPName setting