Problem with one specific assembly

Dec 3, 2007 at 2:19 PM
Hi I have been able to successfully create a lot of solutions using WSPBuilder, but now when I add this specific assembly the .wsp file is not created. I get no error messages or anything, the program just exits.

The assembly is not very complex and is signed with the same key as two other assemblies that I can get in the solution with no problems. It contains a number of webparts and a couple of helper classes.

Is there any limitations that I should be aware of?
Dec 4, 2007 at 6:35 AM
This might be caused if the dll references external types form other dlls other than the normal SharePoint dlls. If this is the case you need to make those dlls visible to WSPBuilder as well. There is an attribute DllReferencePath but I have not gotten it to work so I had to but the external dlls in the solution folder.

I did not get an error message either. Very frustrating.

/ Mats
Dec 4, 2007 at 8:37 AM
Yeah I thought it might be something like that. I downloaded the latest source and tried using that, now it works like a charm and I get error messages when something goes wrong.
Dec 6, 2007 at 3:31 PM
This problem is solved in version