PublishingLayouts

Jun 21, 2007 at 2:17 PM
We are creating our own publishinlayout but all the subfolders seem te get lost??? or are these files (css,xsl,.master etc..) not supported?
Coordinator
Jun 21, 2007 at 5:22 PM
Edited Jun 21, 2007 at 11:26 PM
Please specify your project.
Are you creating a SiteDefinition or a LAYOUTS subfolder?

The wspbuilder should support every kind of file in the Layouts folder. However there was a bug in one of the previous versions, so please ensure that you have the newest version. Currently 0.9.7.0614.
Jun 22, 2007 at 8:31 AM
I have the latest version of the wsp builder.
I'm trying to create a SiteDefinition. Within that SiteDefinition we needed a feature publishinglayout. e.a. subfolder TEMPLATE\FEATURES\myPublishingLayout.

After installing and deploying the solution the subfolder TEMPLATE\FEATURES\myPublishingLayout has no subfolder and I only see the Feature.xml and the ProvisionedFiles.xml
Coordinator
Jun 22, 2007 at 10:06 AM
Edited Jun 22, 2007 at 10:08 AM
Are you missing the <ElementFile> tag in your feature.xml?
This tag enables you to install your files in the feature folder.
Please see this custom feature:

<?xml version="1.0" encoding="utf-8" ?>
<Feature Id="22019288-82bf-4302-8174-c35330376406"
Title="Myfeature"
Description="My feature Description"
Version="1.0.0.0"
Scope="Site"
Hidden="FALSE"
AlwaysForceInstall="TRUE"
xmlns="http://schemas.microsoft.com/sharepoint/">
<ElementManifests>
<ElementManifest Location="Elements.xml" />
<ElementFile Location="MasterPages\MyCustom.master" />
<ElementFile Location="myPublishingLayout\MyLayoutPage.aspx" />
</ElementManifests>
</Feature>

I have specified the <ElementFile> tag to ensure that the MyCustom.master and the MyLayoutPage.aspx gets installed in the feature directory.

I plan however to update the next version of wspbuilder with functionality to solve this "common" mistake more automatically by using the <Resources> tag, more on this later.



MvanKampen wrote:
I have the latest version of the wsp builder.
I'm trying to create a SiteDefinition. Within that SiteDefinition we needed a feature publishinglayout. e.a. subfolder TEMPLATE\FEATURES\myPublishingLayout.

After installing and deploying the solution the subfolder TEMPLATE\FEATURES\myPublishingLayout has no subfolder and I only see the Feature.xml and the ProvisionedFiles.xml



MvanKampen wrote:
I have the latest version of the wsp builder.
I'm trying to create a SiteDefinition. Within that SiteDefinition we needed a feature publishinglayout. e.a. subfolder TEMPLATE\FEATURES\myPublishingLayout.

After installing and deploying the solution the subfolder TEMPLATE\FEATURES\myPublishingLayout has no subfolder and I only see the Feature.xml and the ProvisionedFiles.xml