VS 2008 32 Bit

May 11, 2009 at 5:21 PM

Hi,

I am using VS 2008 and when i have build the new sitedef with master page as a feature and trying to build using "Build WSP" i am getting the following error.

========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========<font size="1">

WSPBuilder

Version: 0.9.8.1029

Created by Carsten Keutmann

GPL License 2007

Building the solution - please wait

Saving the Manifest.xml file

Creating the WSP file

Could not load file or assembly 'CabLib, Version=6.9.26.0, Culture=neutral, PublicKeyToken=85376ef9a48d191a' or one of its dependencies. An attempt was made to load a program with an incorrect format.

 

Can anyone of you help me out in resolving this

</font>

 

May 11, 2009 at 5:28 PM

Sorry found the issue

resolution, replaced the cabLib.dll in C:\Program Files\WSPTools\WSPBuilderExtensions for the x86 version

May 11, 2009 at 5:28 PM

Sorry found the issue

resolution, replaced the cabLib.dll in C:\Program Files\WSPTools\WSPBuilderExtensions for the x86 version

May 19, 2009 at 2:17 PM

I had the same issue and resolved it as well.

I downloaded WSPBuilder Extensions 1.05 - x64 bit and IIS7 support. But this version does not seem to be smart enough to detect that I am on a 32 bit machine. It always installs the 64 bit CabLib.dll. So I ended up having to download the x86 console version of WSPBuilder and just grab the CabLib.dll from there and paste it into windows\system32 and the Program files\WSPBuilder folder.