debugging unable to get solution id from manifest: Unable to extract manifest.xml from:

Feb 16, 2009 at 8:48 PM
Is there a set procedure for debugging the "Unable to get solution id from manifest: Unable to extract manifest.xml ..." error? 

I'm trying to deploy/change/upgrade a web part on our dev box and the only suggestions I can find seem to be "make sure you are using the 64 bit version of cablib.dll." 

I am using the 64 bit version of cablib.dll.  Now what?

Thanks.

Brian
 
Feb 18, 2009 at 3:29 AM
I have exactly the same problem as Brian mentions above, using the 64 bit version of cadlib.dll did not make a difference. I'm using windows server 2003 64 bit with visual studio 2005 professional.

The other thing I have noticed is that the 'copy to 12 hive' function does not seem to work either.
Feb 18, 2009 at 1:19 PM
This may be just voodoo programming but...

I created a new project, scrapping "BrianTest1" in favor of an actual sensible project name, and the new project builds and deploys just fine.  YMMV

Brian


Feb 19, 2009 at 3:22 PM
I'm having this same problem...any help would be appreciated!
Feb 27, 2009 at 12:41 PM
Same issue here on 64bit version
Mar 18, 2009 at 7:42 PM
Same problem here. 64 bit, VS 2008.
Mar 31, 2009 at 12:51 PM
I got the same,. w2008x64 VS2008. Manual deployment seems to work.
Jun 23, 2009 at 8:52 AM

Hi I've got exactly the same issue. w2008 x64, 

Any updates on this issue?

Coordinator
Jun 26, 2009 at 12:43 PM

I know about the problem and will fix it soon.

/keutmann

Jun 26, 2009 at 11:53 PM

just to elaborate, I get the same exact issue when I create a "WSPBuilderProject with Workflow" on a x64 and VS 2008.

haven't tried manual deployment yet.

Jun 29, 2009 at 7:17 PM

Hi,

Any ETA on resolving this?  How can I proceed with installation manually in the meantime?

Jul 22, 2009 at 2:31 PM

Hi

I get the same error as soon as I configure the "Outputpath" property in configuration file WSPBuilder.exe.config .
Commenting it out, i.e. let WSPBuilder place the generated wsp file in the project root folder, solves the problem.

Apparently the deployment commands to not take the Outputpath property into account.

Regards Andreas

Jul 29, 2009 at 11:25 AM

I found I was getting this error message due to a mistake in one of my feature.xml files rather than to any bug in WSPBuilder.

MOSS is very fussy about case in some instances.  I'd written:

<Feature ID="...

Rather than:

<Feature Id="...

D'oh!

Anyway, on the off-chance it helps someone else...