How to fix unavailable WSPBuilder menu in VS 2008

Jan 29, 2009 at 7:52 PM

How to fix unavailable WSPBuilder menu in VS 2008

Problem with unavailable WSPBuilder menu (invoked by right click on project in solution explorer [img 1] or from Tools menu [img 2]) in Visual Studio 2008 can be caused by three reason


[img 1]


[img 2]

  • The first reason can be unchecked Startup checkbox in Add-in Manager.
    Fix is very simple, check Startup checkbox for WSPBuilder [img 3] and if menu do not show after that, try to restart Visual Studio.


[img 3]

  • The second reason can be caused in the case you have installed english version of Visual Studio 2008 on non-english Windows. On Windows XP search english version of Visual Studio 2008 AddIn files in directory "C:\Documents and Settings\All Users\Application Data\Microsoft\MSEnvShared\Addins\" and here is the problem. If you have installed non-english Windows XP, then "Application Data" folder have localized name (for example "Data aplikací" in czech language).
    Fix is as simple as in the first case, create english path "Application Data\Microsoft\MSEnvShared\Addins\" in "C:\Documents and Settings\All Users\" and copy WSPTools.VisualStudio.VSAddIn.AddIn to created path [img 4]. On Windows Vista is fix like on XP.


[img 4]

  • The third reason is simple "It's broken...", try reinstall 1. WSPBuilder, 2. VS, 3. Windows
May 19, 2009 at 9:59 AM

You are right, this solution is successfully in VS 2008 an 2005, thanks for you help, but is other way to don’t create the folder if you have de OS in non English…. You can setup the addins folders in Visual Studio, going to tools Menu, next click in Options, and in the security macros/addins section, add the folder of your addin (Ex. “C:\Documents and Settings\All Users\Datos de programa\Microsoft\MSEnvShared\Addins”), and then click OK, and restart VS.

Aug 24, 2009 at 3:27 PM

The issue I am having is that the menus show up for one project and not the other? I have added all of the folders manually. Should I be creating my VS project via the command line WSPBuilder arguments?

Sep 29, 2009 at 8:05 AM

worked great, thanks