you do NOT have permission to install and deploy sharepoint solutions

Aug 19, 2008 at 3:43 AM
okay what has to be done to get the permissions I need to install and deploy solutions. believe it or not this is not an easy question to answer.
I have talked to SharePoint admins and IT System Admins - they are stumped and have this wierd sound in there voice when they tell me I have full control of the server and sharepoint central admin site. I could really use some help.

Kenneth
Sep 3, 2008 at 6:44 PM
Edited Sep 3, 2008 at 6:45 PM
We are having a similar issue when trying to deploy (or update/uninstall).  The ID I'm using (a domain ID) is a member of the Site Administrators group on the server.    It is an administrator on the server box.  It is a member of the Farm Administrators group in Central Admin.  And it is the site collection administrator.  But whenever this ID tries to run an uninstall or deploy, we receive the message: "User XXXXXX does not have installation permissions on <machine name>.  Preflight requirements failed."  This same ID can run stsadm.exe commands.

I checked the WSPBuilder source and found the specific message.  It appears this message is displayed when the SPFarm.CurrentUserIsAdministrator() returns FALSE.  But if I log into SharePoint with this ID I can manage the farm, site collection, etc... I'm an administrator.  One other point... the ID that was used to create the site is able to run WSPBuilder functions successfully.  Anyone have any idea what all settings need to be done for an ID to be able to run WSPBuilder? 


Oct 30, 2008 at 12:09 AM
Did either of you get an answer to this. I am having the same problem with one of my users.
They are local admin to the system and they are in the farm administrator's group in central admin and they are also the site collection admin for the site.
The SPFarm.CurrentUserIdAdministrator() looks to be returning false.

Thanks,
Oct 30, 2008 at 7:33 AM
Are you sure you have dbowner rights on the content database used by the admin site?
Oct 31, 2008 at 12:10 AM
Thank you for your reply. Yes that was the problem.
-------------- Original message from JeroenRitmeijer : --------------

From: JeroenRitmeijer

Are you sure you have dbowner rights on the content database used by the admin site?
Dec 23, 2008 at 8:51 AM
Thanks Guys, I was stumped on this for a while, so to recap, you need:-

Farm admin
Site collection admin
Web front end admins
DB server admin
and content dbowner

is this right ?
Mar 4, 2009 at 12:29 PM
Edited Mar 4, 2009 at 12:33 PM
I have used WSPBuilder from SQL 2000 to 2008. I only had that problem with SQL 2008, solution:

Since 'mixed auth' was used on the installation, the BUILTIN\Administrators and DOMAIN\account (mine) were not set as SYSADMINs, by setting that using the 'sa' account, right clicking Security => Logins => BUILTIN\Administrators => Server Roles => checking sysadmin, problem solved.

Regards,
Francisco
Mar 24, 2009 at 1:57 PM
Thanks a ton to the contributor's of this thread.  I couldn't seem to find all of the permission levels that I needed to deploy these web parts.  This thread solved that.  Thanks again.