How to install WSPBuilder tool?

Aug 12, 2008 at 2:55 PM
Hi,
I am new to SharePoint development and coming from a short training class. we were using WSPBuilder for the training. Coming to office I was trying to install the WSPBuilder tool and set up the development environment. How can I install the tool? Would you mind giving me the detailed steps for installation? I have tried to read from the site but didn't get the information I am looking which is all about installing the tool and making it working with Visual Studio 2005.
Any help please?
Thank you in advance,

 

Coordinator
Aug 16, 2008 at 12:20 AM
Edited Aug 16, 2008 at 12:21 AM

Hi

You just have to download the WSPBuilder Extensions 1.0.3 and install the MSI file.

Remember to restart Visual Studio.

Then in Visual Studio, you create a WSPBuilder project, you can also use other project types. Create a new Item where you select one of the WSPBuilder item templates. Then you build the solution by selecting in the menubar "Tools > WSPBuilder -> Build WSP"

/keutmann

Nov 4, 2010 at 8:18 AM

HI,

I got same problem. When I installed WSPbuilder I can't see it in Templates. I am using Visual Studio 2010, Windows Server 2008 R2 and SharePoint 2007. I am confused because installation is without problems and even if I restart Visual Studio everything is the same.

Any help please?

Thank you a lot

Nov 11, 2010 at 1:08 AM

Hi,

 

I installed WSPBuilder Extensions 1.06 as I am using Visual Studio 2010. I dont see any templates for WSP Builder and also nothing gt added in project context menus (Like in VS 2008, where we used to create WSP by rght clicking the project and selecting the Build WSP).

My guess is that I am missing something here, please let me know if you faced simlar issues and got a solution.

Thanks.

Jan 3, 2011 at 9:20 PM

Same here,

I installed 1.06 and I am using VS 2010 and Windows server 2008. I don't get the WSP project template when I click file/new porject. I have looked through all the installed templates and WSP is not listed. However the install of WSPBuilder Extensions 1.06 worked without any errors.  Does any other extenions need to be installed first?

Thanks,

Jan 3, 2011 at 9:24 PM

Another note. Under VS2008 WSPBuilder is listed under tools and in the add-in manager. It is not listed there in VS2010. Seems the install is not working correctly. VS2008 is on the same Windos server 2008 and it has WSPBuilder.