Redeploying a Solution with WSPBuilder

Oct 27, 2011 at 8:06 PM


I am wondering what the proper steps are for redeploying a solution with WSPBuilder.  I have coded up an event handler and have been able to build and deploy it to my SharePoint environment via Visual Studio's Tools > WSPBuilder > Build WSP/Deploy.  I, however, have updated the code to the event handler and was wondering if I have to now uninstall the deployed solution (Visual Studio's Tools > WSPBuilder > Uninstall) before building and deploying again?  Or can I merely build and deploy?


Oct 27, 2011 at 10:03 PM


You should just have to ReBuild your solution clicking [Build WSP], then click [Upgrade].

Hope this help!


Oct 28, 2011 at 8:34 PM

Thanks for the prompt reply JH!  You ROCK! 

Just out of curiosity, if I had just used the Build WSP and Deploy actions to redeploy, would my latest code updates have pushed through?

Oct 28, 2011 at 8:56 PM


My pleasure s_t!

I've never done so before.

But after every time I've modified my coding, I always 1st:ReBuild my solution, 2nd:Rebuild the WSP (by clicking Build WSP), 3rd:ReDeploy (by clicking Upgrade).

This is just me try to be on the safe side, maybe someone else could give you better answer, I hope. ;)

Hope this help!


Oct 28, 2011 at 9:01 PM


Thanks for your additional input and for sharing your workflow.  This will help me greatly.

Take care!


[Now, it's back to troubleshooting why my event handler isn't running as I want it to - :( ]


Oct 28, 2011 at 9:12 PM


I'm glad I could help!

Just in case you've not done so, I always use this link to get help on troubleshooting my code issues ",sharepoint/".

Hope this can help you in your Event Handler issue! :)

Thanks & you take care too!


Oct 28, 2011 at 9:19 PM


Thanks for the link!  I'm new to SharePoint development and I'm sure this resource will come in handy.