WSPBuilder 2010 - Problems with deployment

Apr 4, 2011 at 3:36 PM

Hello

I have the following problem. I created a Webpart Feature with WSPBuilder 2010, created the corresponding deployment folder (on a dev machine) and tried to deploy it on a testserver. The deployment on first sight looks good (central administration), but the assembly is not deplyoed to the GAC nor is the Assembly marked as a Safecontrol in Web.Config. Then I installed Visual Studio and tried to deployed it directly from there. In this case I get the following error messages:

Microsoft SharePoint Services Administration is not running on LABVM02
Microsoft SharePoint Services Timer is not running on LABVM02
Preflight requirements failed.

I checked the services and they are running. Also Visual Studio is running under Administrator Priviliges.

What could be the problem?

Apr 4, 2011 at 3:55 PM

I had the same issue before which was not able to deploy to GAC or Assembly.

Someone else advice me to change the solution from .Net4.0 to .Net3.5, and that fix it for me.

Please try that if you have not yet done so.

 

Good luck!

JH

Apr 5, 2011 at 9:27 AM

I checked this already.... It's .Net 3.5 

Any other ideas?

Apr 5, 2011 at 2:20 PM

You might have done this already, but I still suggest you to restart the server.

I'm not a server guy, so I've a server tech, and I asked him.

He said sometime the service account password change, the server could indicate that's running but it's not. Just to be sure, he said it's better to restart the server, then double check to make sure the services are running.

Hope this help.

JH

Apr 6, 2011 at 10:02 AM

Restarting the Server was unfortunately the first thing I did... had still the problem

Apr 6, 2011 at 2:22 PM

Please take a look at this

http://www.whatsthepointofsharing.com/2009/02/04/wsp-buildermicrosoft-sharepoint-services-administration-is-not-running/

and

http://madtechnology.wordpress.com/2008/06/24/wsp-builder-for-sharepoint-microsoft-sharepoint-services-timer-is-not-running-error/

http://social.technet.microsoft.com/Forums/en-IE/sharepointadmin/thread/4f1b3aaf-7173-4151-874b-5740bff4b14f