Unmanaged dll file excluded from WSP Package

Mar 31, 2011 at 6:13 PM

Hi,

I am currently using the following: Windows 7 Professional, VS2010, SharePoint 2010 & .Net Framework 4 as a target.

I have downloaded WSPBuilder Extensions 1.0.6 and also tried WSPBuilder Extensions 2010 BETA1.4

I couldn't successfully get my webparts to work on sharepoint due to the fact that my .dll file doesn't get deployed to the gac. Whenever I try to build a wsp file using the WSPBuilder, I see the message:

The assembly C:\MyPath\MyAssemblyName.dll is unmanaged. The assembly will be excluded from the WSP package!

I have also verified that the dll file is not in the .wsp file whenever I try to rename it to .cab and explore it. I used to use Framework 3.5 and it works just fine. I can't go back to 3.5 though because I am using some namespaces only available in 4.

Any help is appreciated...

Thank you!

 

Apr 1, 2011 at 4:38 AM

Put simply, You cannot use .net4 with SharePoint 2010 - You must use 3.5

So you have to rework your code to use the 3.5 version of the framework, and this is also the most likely cause of your error (.net4 is not reconized).

Jan 26, 2012 at 11:08 AM

Hi,

I wonder if we can use WSPBuilder on VS2010 to build solutions for MOSS 2007

I tried using it to build a package for MOSS 2007, using both 3.0 and 3.5 framework, but it it displays the same error message as mentioned above

Anyone can help on that ?

Thanks in advance