No symbols loaded when attaching to process with wspbuilder

Jan 11, 2011 at 10:57 AM
Edited Jan 11, 2011 at 11:02 AM

Hello there

I all of a sudden got  the notorious No symbols loaded error.

It was an open project in visual studio 2010, and no reboots etc has taken place. All of a sudden I got this.

I got it plenty of times before in 2007, but usually it was a product of getting an error when copying to GAC, and once I started looking for that error every time I placed DLL in GAC it was no longer a problem. I would just add it again.

I have tried the following that usually always works for me.

- Delete the files in the debug dir
- Reset iis
- Closed and opened visual studio
- Removed dll from gac and readded
- Made a change in dll and recompiled.
- Unchecked "Only My Code" in the debugger settings
- Made sure debug was activated in web.config
- Made sure debug was not disabled in aspx page.

I attach at the right time, meaning I recycle app pools, wait a moment for them to complete, load the page I debug (application page in sharepoint 2010), then attach.

The strange thing is I only get this error when attaching to the process with WSPBuilder. If I attach manually through VS2010 I can debug just fine.

It seems it keeps attaching to the wrong process for some reason.

Anyone who has had this problem, or got any ideas?

I really save a lot of time attaching with WSPbuilder, and it has always worked very well for me. The wspbuilder process attach is especially nice now that I get a confirmation prompt I need to click for each w3 process, and usually have 4 or 5 of them.

Best Regards,