how to deploy more than webparts

Oct 5, 2007 at 7:47 AM
Edited Oct 5, 2007 at 8:16 AM
i'm new in sharepoint development and deployment ......


I was trying to deploy more than one webpart using WSPBuilder but i'm facing problem how to install web part Dll in GAC .

i have made one library project create folder structure put all feature.xml , element file in features folder , and .webpart file within wpcatalog folder and all webpart dll in GAC folder. build solution and made WSP file using WSPBuilder.EXE

when i start deployment i got one message like "Failed to exract the Cab file in solution" .

if i donot put webpart Dll in GAC folder webpart deploy successfully but manually need to put Dll in WINDOW\Assembly\ .

send me procedure how to deploy more than one webpart using WSPBuilder in details .

and Some code about SetUp.EXE .
Oct 8, 2007 at 6:35 AM


pushpendrag wrote:
i'm new in sharepoint development and deployment ......


I was trying to deploy more than one webpart using WSPBuilder but i'm facing problem how to install web part Dll in GAC .

i have made one library project create folder structure put all feature.xml , element file in features folder , and .webpart file within wpcatalog folder and all webpart dll in GAC folder. build solution and made WSP file using WSPBuilder.EXE

when i start deployment i got one message like "Failed to exract the Cab file in solution" .

if i donot put webpart Dll in GAC folder webpart deploy successfully but manually need to put Dll in WINDOW\Assembly\ .

send me procedure how to deploy more than one webpart using WSPBuilder in details .

and Some code about SetUp.EXE .



i have done